[Logo] Spazio Aperto Banca Sella
[Register] Registrati   [Login] Login    
[Search] Ricerca   [Recent Topics] Argomenti Recenti   [Hottest Topics] Argomenti vivaci  
[Banner Pubblicitario]
Messaggi inviati da: SIRINFOSRL
Indice dei Forum » Profilo per SIRINFOSRL » Messaggi inviati da SIRINFOSRL
Autore Messaggio
Mi rispondo solo dopo aver capito come procedere (spero sia di aiuto a qualcuno).
Se si utilizzano i web service:
- abilitare il protocollo TLS 1.2 sul server che dialoga con banca sella (per fare ciò ho inserito delle chiavi di registro di windows in sezione "SecurityProviders"
-abilitare le cipher suites tramite maschera di editor criteri di gruppo locali e "impostazioni di configurazione SSL", "ordine dei pacchetti di crittografia SSL"
- inserire nella propria applicazione web ( che richiama il webservice di banca sella) un istruzione che indica che si inizia una trasmissione con protocollo TLS 1.2
ho usato istruzione seguente prima di iniziare la transazione
ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12;Per fare ciò ho dovuto aggiornare la mia applicazione da .NET Framework 2.0 a 4.5

Abbiamo problemi con pagamenti tramite Gestpay.
L'errore è del tipo: the underlying connection was closed: An unexpected error occurred on a send
Cioè il nostro server non è autorizzato a collegarsi ai vostri sistemi.
Ho abilitato il protocollo TLS 1.2 (aggiungendo delle chiavi di registro al nostro server windows 200 ma adesso non ho capito come
faccio ad installare una delle cypher suites da voi richieste ?

Le cypher suites da voi indicate sono:
TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (0xc030)
TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 (0xc02f)
TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384 (0xc02
TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA (0xc014)
TLS_RSA_WITH_AES_256_GCM_SHA384 (0x9d)
TLS_RSA_WITH_AES_256_CBC_SHA256 (0x3d)
TLS_RSA_WITH_AES_256_CBC_SHA (0x35)
TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256 (0xc027)
TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA (0xc013)
TLS_RSA_WITH_AES_128_GCM_SHA256 (0x9c)
TLS_RSA_WITH_AES_128_CBC_SHA256 (0x3c)
TLS_RSA_WITH_AES_128_CBC_SHA (0x2f
Mi associo anche io alla domanda
OK,Grazie per i chiarimenti
Buongiorno,
potete darmi supporto?
Grazie
Buongiorno
Nell'email ricevuta in questi giorni c'è scritto:
"Effettua alcune prove con il supporto del tuo Staff Tecnico utilizzando l'ambiente di test https://testecomm.sella.it, per verificare il corretto funzionamento ed evitare malfunzionamenti quando il protocollo SSL 3.0 non sarà più accettato".
Avrei alcuni dubbi e domande da fare.
premetto che:
- il collegamento del cliente al nostro sito di e-commerce (che utilizza Gestpay starter) avviene con una normale connessione (l'utente per intenderci si collega col browser digitando http:\\mio_ip_server) e non viene utilizzata la crittografia (il cliente non si collega con https:\\ ecc..)
-utilizzo l' interfaccia web service WsCryptDecrypt su https://ecomms2s.sella.it;

Immagino quindi che non debba apportare modifiche all'applicazione.
Se anziché collegarmi all'ambiente reale (https://ecomms2s.sella.it) mi collego all'ambiente di test (https://testecomm.sella.it) utilizzerò' già intrinsecamente il protocollo TLS 1.0 e potrò' verificare se ci sono eventuali problemi?
Grazie


Se la versione di gestpay è quella starter non posso aggiungere campi e parametri,per cui non posso sapere se l'utente ha pagato con bonifico,Vero ?
Se un cliente acquista con bonifico classico, ho la possibilità dai dati della transazione ricevuti da gestpay di capire che si tratta proprio
di un pagamento con bonifico e non di un pagamento con carta?
(Serve saperlo per non inviare immediatamente una chiave di licenza software al cliente che acquista un software dal nostro sito,
ma aspettare l'esito realmente positivo del pagamento con bonifico che avviene entro qualche giorno)
E' possibile rendere il CVV obbligatorio con gestpay starter ?
Nel Back Office di TEST in"configurazione cliente" / "Campi e parametri"
riuscivo ad impostare i campi che passo a gestpay durante la transazione:
(es. Buyer e-mail e Buyer Name" )
Nel back office REALE,appena attivato, se scelgo il menu' corrispondente appare il messaggio:
Attenzione La funzionalità selezionata non è disponibile per la versione corrente di GestPay

Possibile che tale funzione non è disponibile???

Ho letto nel forum ,cercando l'errore "1107" quanto segue:
"Ricordo che per rendere le modifiche effettive è necessario pubblicare la pagina di pagamento su cui sono state fatte le variazioni. "
Adesso mi chiede i campi obbligatori correttamente.
Grazie ugualmente
Ho notato che se anche se imposto"Buyer Name" obbligatorio,ovvero vorrei che fosse un campo richiesto obbligatoriamente all'acquirente durante il pagamento,
non mi viene richiesto come obbligatorio durante il pagamento stesso.
Non mi è chiaro il meccanismo per i campi obbligatori.

In particolare:
-se imposto un campo obbligatorio(es. buyer name) e passo a gestpay una stringa vuota
allora la fase I della transazione è superata ,ma poi il come del compratore non viene richiesto come campo obbligatorio
-se invece imposto io il buyer name (perchè lo conosco essendo un utente registrato del sito che vuole acquistare) e invoco il web service
mi viene risposto "nome parametro non previsto" nell'errorDescription

Buonasera
vorrei che il campo CVV sia obbligatorio,ma anche se ho impostato nel back office , in "campi & parametri", il check su "Input" e sul nome del parametro
per cui vedo
Cvv √ √
non viene richiesto in fase di acquisto; dove sbaglio ??
OK, siete incredibilmente veloci nelle risposte!
Mi ero accorto del problema e stavo scrivendo la soluzione perche' magari possa essere utile in futuro a qualcuno che utilizza .NET e pagine aspx, ma mi avete anticipato.
Mi sono accorto che avevo messo nel file web.config una limitazione di accesso alla pagina associata all'-"URL Server to Server"
del tipo :
<location path="frmRegistrationRequestComplete.aspx">
<system.web>
<authorization>
<deny users="?"/>
</authorization>
</system.web>
</location>

per cui effettivamente il vostro server non poteva raggiungerla in quanto veniva chiesta l'autenticazione/il login
Grazie 1000!
Buongiorno , ho impostato tutti e tre i seguenti parametri:
-URL per risposta positiva
-URL per risposta negativa
-URL Server to Server"
del mio negozio virtuale di prova (Codice Esercente: GESPAY59600)

Ho verificato che quando simulo l&#039;abbandono da parte dell&#039;acquirente di una transazione vengo reindirizzato (correttamente) alla pagina di esito negativo
tuttavia non sembra che venga richiamato l&#039;URL Server to Server.Potreste aiutarmi?


 
Indice dei Forum » Profilo per SIRINFOSRL » Messaggi inviati da SIRINFOSRL
Vai a:   
E.t.v.s.p.b WLS11G