[Logo] Spazio Aperto Banca Sella
[Register] Registrati   [Login] Login    
[Search] Ricerca   [Recent Topics] Argomenti Recenti   [Hottest Topics] Argomenti vivaci  
[Banner Pubblicitario]
Messaggi inviati da: sgkataweb
Indice dei Forum » Profilo per sgkataweb » Messaggi inviati da sgkataweb
Autore Messaggio
Nel precedente post esprimevo il dubbio che il problema dipendesse dal firewall presente sulla rete, lasciando però aperta la domanda sulla risposta ricevuta che comunque, secondo me, non avrebbe dovuto avere quel formato.

Oggi mi sono procurato una chiavetta (aggirando in questo modo il firewall aziendale), ho configurato il nuovo ip nel backoffice ed ho riprovato, ma la risposta è stata la stessa indicata sopra: pagamento corretto, risposta KO senza nessuna spiegazione.

Cosa devo fare?

Simone
Il problema sembrerebbe legato al firewall.

Comunque la risposta resta misteriosa.

Simone

Non so cosa dire.

Dopo che per N volte ho provato in tutti i modi, alla fine ho cancellato tutti i cookie ed adesso sembra funzionare.

Comportamento molto strano.

Comunque grazie

Simone
Ho effettuato in test un pagamento corretto (così da mail ricevuta) ma l'operazione di decrypt ha dato questo risultato

<?xml version="1.0" encoding="UTF-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlnssi="http://www.w3.org/2001/XMLSchema-instance" xmlnssd="http://www.w3.org/2001/XMLSchema">
<soap:Body>
<DecryptResponse xmlns="https://ecomm.sella.it/">
<DecryptResult>
<GestPayCryptDecrypt xmlns="">
<TransactionType>DECRYPT</TransactionType>
<TransactionResult>KO</TransactionResult>
<ShopTransactionID>primoacquisto</ShopTransactionID>
<BankTransactionID/>
<AuthorizationCode/>
<Currency>242</Currency>
<Amount>1.1</Amount>
<Country/>
<CustomInfo/>
<Buyer>
<BuyerName/>
<BuyerEmail/>
</Buyer>
<TDLevel/>
<ErrorCode/>
<ErrorDescription/>
<AlertCode/>
<AlertDescription/>
<VbVRisp/>
<VbVBuyer/>
<VbVFlag/>
<TransactionKey/>
</GestPayCryptDecrypt>
</DecryptResult>
</DecryptResponse>
</soap:Body>
</soap:Envelope>

KO ma nessuna informazione di errore e nessun dato.
Che vuol dire?

Simone
Gentile BancaSella,
come mai se cerco nel forum 8008 non viene evidenziato nessun risultato ben sapendo che invece c'è un post che contiene questa ricorrenza?

https://forum.sella.it/spazioaperto/posts/list/99202.page

Grazie

Simone
Scusate,
mi sono accorto solo ora della parte in fondo dove vengono indicati i parametri obbligatori.

Dove posso trovare indicazione sul significato degli stessi?

<s:element minOccurs="1" maxOccurs="1" name="Red_CustomerInfo" nillable="true" type="tns:RedCustomerInfo"/>
<s:element minOccurs="1" maxOccurs="1" name="Red_ShippingInfo" nillable="true" type="tns:RedShippingInfo"/>
<s:element minOccurs="1" maxOccurs="1" name="Red_BillingInfo" nillable="true" type="tns:RedBillingInfo"/>
<s:element minOccurs="1" maxOccurs="1" name="Red_CustomerData" nillable="true" type="tns:RedCustomerData"/>
<s:element minOccurs="1" maxOccurs="1" name="Red_CustomInfo" nillable="true" type="tns:RedCustomInfo"/>
<s:element minOccurs="1" maxOccurs="1" name="Red_Items" nillable="true" type="tns:RedItems"/>

Grazie.

Simone
Osservando le definizioni che restituisce https://testecomm.sella.it/gestpay/gestpayws/WSCryptDecrypt.asmx?WSDL

quello che osservo è che, per esempio, il parametro shopLogin

<s:element minOccurs="0" maxOccurs="1" name="shopLogin" type="s:string"/>

Avendo minOccurs="0" e maxOccurs="1" non è considerato obbligatorio,

Se fosse obbligatorio avrebbe dovuto essere:

<s:element minOccurs="1" maxOccurs="1" name="shopLogin" type="s:string"/>

E' corretto?
Come faccio a sapere quali parametri sono obbligatori?

Simone
Questo è quanto ottengo:

<?xml version="1.0" encoding="UTF-8"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlnssi="http://www.w3.org/2001/XMLSchema-instance" xmlnssd="http://www.w3.org/2001/XMLSchema"><soap:Body><EncryptResponse xmlns="https://ecomm.sella.it/"><EncryptResult><GestPayCryptDecrypt xmlns=""><TransactionType>ENCRYPT</TransactionType><TransactionResult>KO</TransactionResult><ErrorCode>1008</ErrorCode><ErrorDescription/></GestPayCryptDecrypt></EncryptResult></EncryptResponse></soap:Body></soap:Envelope>

Credo che sia una vostra risposta. O no?

Simone
Non ho trovato documentazione su questo errrore né vi è l' ErrorDescription nella risposta.
Qualcuno sa di che tipo di errore si tratti?

E' disponibile un elenco completo degli errori otre alla lista di quelli più comuni che è disponibile?

Grazie

Simone
 
Indice dei Forum » Profilo per sgkataweb » Messaggi inviati da sgkataweb
Vai a:   
E.t.v.s.p.b WLS11G